Senin, 27 Februari 2012

KONSEP DNS


DNS mirip dengan sebuah buku telepon. Masing-masing komputer pada Internet mempunyai baik nama host maupun alamat IP (Internet Protocol). Terutama sekali, ketika Anda ingin berhubungan ke komputer lain, Anda harus memasukkan sebuah nama host. Komputer Anda kemudian menghubungi sebuah server DNS yang melakukan rujuk silang nama host yang Anda sediakan ke alamat IP sebenarnya. Alamat IP ini kemudian dipakai untuk berhubungan ke komputer jarak jauh.  Sebelum implementasi DNS, pembuatan nama-nama komputer yang mudah dikenali sudah dilaksanakan dengan memakai file-file HOSTS yang memuat suatu daftar nama dan alamat IP yang berkaitan. Di dalam Internet, file ini diurus secara sentral dan masing-masing lokasi akan men-download sebuah salinan yang baru secara periodik. Ketika jumlah komputer di dalam Internet bertambah banyak, hal ini menjadi suatu solusi yang tidak dapat dikelola. Akibatnya, DNS didesain untuk menggantikan file HOSTS yang diurus secara tunggal dengan suatu database terdistribusi yang akan memungkinkan adanya spasi untuk nama berbentuk hierarkis, distribusi administrasi, tipe-tipe data yang dapat diperluas, ukuran database yang tak terbatas secara virtual, dan unjuk kerja yang lebih baik. DNS adalah layanan nama bagi alamat Internet yang menerjemahkan nama-nama domain yang sudah dikenali ke alamat IP numerik. Misalnya, www.datakom.com menerjemahkan menjadi 192.168.53.1. DNS dapat disamakan dengan sebuah buku telepon. Pemakai melihat nama orang atau organisasi yang ingin ia hubungi dan lakukan rujuk silang nama itu ke sebuah nomor telepon. Demikian pula sebuah komputer host meragukan nama sebuah komputer dan sebuah server nama domain melakukan rujuk silang nama itu ke sebuah alamat IP.


Konsep & Cara Kerja DNS
DNS (Domain Name System) adalah suatu system yang mengubah nama host (seperti linux.or.id) menjadi alamat IP (seperti 64.29.24.175) atas semua komputer yang terhubung langsung ke Internet. DNS juga dapat mengubah alamat IP menjadi nama host.
DNS bekerja secara hirarki dan berbentuk seperti pohon (tree). Bagian atas adalah Top Level Domain (TLD) seperti COM, ORG, EDU, MIL dsb. Seperti pohon DNS mempunyai cabang-cabang yang dicari dari pangkal sampai ke ujung. Pada waktu kita mencari alamat misalnya linux.or.id pertama-tama DNS bertanya pada TLD server tentang DNS Server yang melayani domain .id misalnya dijawab ns1.id, setelah itu dia bertanya pada ns1.id tentang DNS Server yang bertanggung jawab atas .or.id misalnya ns.or.id kemudian dia bertanya pada ns.or.id tentang linux.or.id dan dijawab 64.29.24.175
Sedangkan untuk mengubah IP menjadi nama host melibatkan domain in-addr.arpa. Seperti domain lainnya domain in-addr.arpa pun bercabang-cabang. Yang penting diingat adalah alamat IP-nya ditulis dalam urutan terbalik di bawah in-addr.arpa. Misalnya untuk alamat IP 64.29.24.275 prosesnya seperti contoh linux.or.id: cari server untuk arpa, cari server untuk in-addr.arpa, cari server untuk 64.in-addr.arpa, cari server 29.64.in-addr.arpa, cari server untuk 24.29.64.in-addr.arpa. Dan cari informasi untuk 275.24.29.64.in-addr.arpa. Pembalikan urutan angkanya memang bisa membingungkan.

PENGERTIAN DNS


Penggunaan nama sebagai pengabstraksi alamat mesin di sebuah jaringan komputer yang lebih dikenal oleh manusia mengalahkan TCP/IP, dan kembali ke jaman ARPAnet. Dahulu, setiap komputer di jaringan komputer menggunakan file HOSTS.TXT dari SRI (sekarang SIR International), yang memetakan sebuah alamat ke sebuah nama (secara teknis, file ini masih ada – sebagian besar sistem operasi modern menggunakannya baik secara baku maupun melalui konfigurasi, dapat melihat Hosts file untuk menyamakan sebuah nama host menjadi sebuah alamat IP sebelum melakukan pencarian via DNS). Namun,, sistem tersebut diatas mewarisi beberapa keterbatasan yang mencolok dari sisi prasyarat, setiap saat sebuah alamat komputer berubah, setiap sistem yang hendak berhubungan dengan komputer tersebut harus melakukan update terhadap file Hosts.
Dengan berkembangnya jaringan komputer, membutuhkan sistem yang bisa dikembangkan: sebuah sistem yang bisa mengganti alamat host hanya di satu tempat, host lain akan mempelajari perubaha tersebut secara dinamis. Inilah DNS.
Paul Mockapetris menemukan DNS di tahun 1983; spesifikasi asli muncul di RFC 882 dan 883. Tahun 1987, penerbitan RFC 1034 dan RFC 1035 membuat update terhadap spesifikasi DNS. Hal ini membuat RFC 882 dan RFC 883 tidak berlaku lagi. Beberapa RFC terkini telah memproposikan beberapa tambahan dari protokol inti DNS.